Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 21, 2020 - 21:00 UTC
Scheduled
Due to network maintenance, there will be an outage of up to 30 minutes within the scheduled maintenance window. We apologise for any inconvenience caused.
Posted Jul 08, 2020 - 11:29 UTC
This scheduled maintenance affected: Websites (https://www.heliosnet.com/) and Email (@heliosnet.com).